July 20th, 2017
ilyena_sylph: jareth with lyrics from 'as the world falls down' (Labyrinth: world falls down)
wild_irises: (hulk smash for free)
wild_irises: (Phil Ochs)
July 10th, 2017
frobzwiththingz: (bridgeport)
posted by [personal profile] frobzwiththingz at 06:02pm on 10/07/2017 under
So, just a couple of days before heading up to Firefly, my 2005 Scion xB started acting up, occasionally running rough and sometimes stalling when dropping down to idle, but somewhat intermittently. It eventually lit the MIL status light and I extracted out the code P0122 out of it with the OBD2 reader I have. Ok, thats the Throttle Position Sensor being flaky. I found that wiggling the connector wires as best as I could given the awkward location of the back of the throttle plate is in an xB (hidden behind the air intake cluster and radiator hoses) seemed to make things a little better, and given that of course, the calendar date meant that Acton Toyota and pretty much all other auto shops would be closed until after the holiday, I decided that the current behavior *probably* wouldn't degrade and strand me on the way up to Firefly, so I took the vehicle, stuffed it full of camping gear and lasers and propane tanks and fire art and LED Tetris and L&I drove up to Firefly. Car did make it just fine, with not even any abnormal behavior, and continued to behave just fine until the return trip, which started out just fine, including a visit to Worthy Burger in South Royalton, VT, (whose burgers are indeed worthy and their beer selection is very good too), followed by driving south until I F'd up and got onto 93 North in Concord NH rather than South. So i get off at the next exit, and turn around in the gas station that was there, with L right behind me, and I explain to her "Oops, I F'd up and took the wrong exit, i'm now looking to get back on 93 in the right direction..." whereupon after running just fine my xB suddenly loses all power trying to get back onto 93 north and barely manages to limp along enough to get off of the entrance ramp and far enough along on 93 to be able to pull over onto the shoulder. I now explain to L "Um, xB has lost all power. I'm going to frob around with the TPS connector again and see if I can get it going again, otherwise it's Adventure Time with AAA"

Mucking around with the connector and wires a bit while moving the throttle by hand eventually produces a seemingly running engine again, and we manage to then drive back to Westford MA without further incident.

Problem seems pretty clearly local to the throttle position sensor or it's connector, so instead of going to a shop and dropping significant $$$ I called up Auto Zone and asked if they could supply me with a replacement sensor for my xB; they had one in stock and I borrowed L's xB and picked it up. Duralast part number TPS4117. I was wearing zero pieces of flair but they sold it to me anyway.

Anyhow, it's in a hard to get at location without removing other shit, so I had to take out the air intake stuff in order to get at the connector enough to disconnect it and remove the sensor: but I dike out the air intake and air filter holding enclosures until I can have good access to everything, whereupon I find this:




Well, golly, that yellow wire looks to be in *great* shape! (Not). Ok, I probably don't really need the new sensor, I actually need a soldering iron and some heat-shrink tubing.



Cut wire at broken location, stripped, soldered, heat-shrunk, etc, and reassembled everything; everything proceeded to work just fine and no more engine codes. Drove it back to Auto Zone and returned the unused sensor. Yay!   

I wonder what various shops in the area would have told me, and what they would have charged for the service. I wonder if *any* of them would have simply told me about the broken wire and just fixed *that*. 










 


April

SunMonTueWedThuFriSat
          1
 
2
 
3
 
4
 
5
 
6
 
7 8
 
9
 
10
 
11
 
12
 
13
 
14
 
15
 
16
 
17
 
18
 
19
 
20
 
21
 
22
 
23
 
24
 
25
 
26
 
27
 
28
 
29
 
30